Fedora linux forum

Форум русской поддержки ОС Fedora linux

Сервис определения победителей в инстаграм топ сервисов для проведения конкурсов в инстаграм. 

#1 2009-12-18 16:38:01

KOPTEC
New member
Откуда: Одесса
Зарегистрирован: 2009-12-18
Сообщений: 6

Проблема с обновлением с 9 на 10

начну с самого главного — линуксе я полный юзвер... просьба не кидаться тухлыми яйцами, помогите разобраться
yum -y update и в какой-то момент выполнения вылазит следущее:

--> Processing Dependency: libcap.so.1 for package: libcap-debuginfo
--> Processing Dependency: libcap.so.1 for package: avahi
---> Package kdeedu-marble-libs.i386 0:4.3.3-1.fc10 set to be updated
---> Package inchi.i386 0:1.0.2-0.3.fc9 set to be updated
--> Processing Conflict: sysklogd conflicts syslog-ng
--> Processing Conflict: kdeedu-marble conflicts kdeedu-libs < 4.2.0
--> Finished Dependency Resolution
sysklogd-1.5-7.fc10.i386 from updates has depsolving problems
  --> sysklogd conflicts with syslog-ng
avahi-0.6.17-1.fc7.i386 from installed has depsolving problems
  --> Missing Dependency: libcap.so.1 is needed by package avahi-0.6.17-1.fc7.i386 (installed)
kdeedu-marble-4.3.3-1.fc10.i386 from updates has depsolving problems
  --> kdeedu-marble conflicts with kdeedu-libs
libcap-debuginfo-2.06-3.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: libcap.so.1 is needed by package libcap-debuginfo-2.06-3.fc9.i386 (installed)
Error: Missing Dependency: libcap.so.1 is needed by package avahi-0.6.17-1.fc7.i386 (installed)
Error: sysklogd conflicts with syslog-ng
Error: kdeedu-marble conflicts with kdeedu-libs
Error: Missing Dependency: libcap.so.1 is needed by package libcap-debuginfo-2.06-3.fc9.i386 (installed)

что это значит и как с ним бороться?

Неактивен

 

#2 2009-12-22 12:39:16

ash
Moderator
Откуда: Мурманск
Зарегистрирован: 2007-10-21
Сообщений: 382

Re: Проблема с обновлением с 9 на 10

Попробуй preupgade или обнови с диска. Сам не пользовался, обычно переустанавливаю систему.

Кстати, цитата самого Tigro по поводу обновления:

И ещё хочу сказать всем, хотите проблем — обновляйтесь. Юмом, preupgrade’ом, через инсталлятор, это лично ваши проблемы. У меня тоже иногда обновлялось хорошо, но обычно это пустая трата времени. Нужно выработать стратегию по обновлению дистрибутивов (там отдельный /home и т. п.) и всегда, придерживаясь её, ставить дистрибутив начисто. Тогда многие проблемы просто не возникнут.

И да, в будущем выбирай раздел в соответствии с тематикой вопроса.

Неактивен

 

#3 2009-12-22 16:46:49

Mak_s
Member
Откуда: Чернигов
Зарегистрирован: 2009-12-06
Сообщений: 358

Re: Проблема с обновлением с 9 на 10

KOPTEC написал:

Error: Missing Dependency: libcap.so.1 is needed by package avahi-0.6.17-1.fc7.i386 (installed)
Error: sysklogd conflicts with syslog-ng
Error: kdeedu-marble conflicts with kdeedu-libs
Error: Missing Dependency: libcap.so.1 is needed by package libcap-debuginfo-2.06-3.fc9.i386 (installed)

что это значит и как с ним бороться?

Значит это именно то, что написано (пропущенные зависимости и конфликты пакетов), а бороться с этим надо в индивидуальном порядке. Для конфликтов в простейшем случае нужно удалить (или исключить из установки) один из конфликтующих пакетов (если от него не зависят другие критичные пакеты). А для пакетов с пропущенными зависимостями скорее всего придется скачивать новые аналоги и устанавливать принудительно через rpm. Но это добавит еще больше мусора в и без того не очень чистую систему (судя по тому, что в ней присутствуют пакеты еще с семерки). Поэтому лучший способ, как сказал ash, установить новую систему с нуля (предварительно сохранив всю нужную информацию, конечно).


Круче самовара только титан

Неактивен

 

#4 2009-12-25 17:04:07

KOPTEC
New member
Откуда: Одесса
Зарегистрирован: 2009-12-18
Сообщений: 6

Re: Проблема с обновлением с 9 на 10

Mak_s, верно заметил — система была установлена с диска семерки и обновлена до девятки при помощи preupgrede'а.
ash, пробовал обновлять всеми возможными методами (в том числе и обновление с диска) и действительно это пустая трата времени — само обновление проходит удачно но после пеерезагрузки (необходимой для завершения обновления) сисема не стартовала по вине загрузчика — либо его на прочь сметало либо лихорадочно выводилась на монитор надпись GRUB. Сам загрузчик перезаписи/востановлению не поддавался... Так что установил систему я с чистого нуля smile
спасибо что откликнулись!

Отредактированно KOPTEC (2009-12-25 17:04:25)

Неактивен