Fedora linux forum

Форум русской поддержки ОС Fedora linux

 

#1 2007-10-29 17:08:16

Deniska
New member
Зарегистрирован: 2007-10-29
Сообщений: 4

Поясните с обновлением ПО

Здравствуйте.
Подскажите, пожалуйста, как обстоят дела в FC с обновлением установленного программного обеспечения. Суть вопроса в следующем — достался мне FC4 сервер на площадке провайдера. Устанавливаю софт (скажем хоть тот же apache) через yum. НО, ставится версия, далеко не самая свежая. И так со всеми программами — куда не возьмись, везде либо устаревшая версия, либо вообще узкий выбор (скажем для FC4 mysql только 4 версии).
Так как же быть с обновлениями? Менять репозитории yum? А где их брать? Ставить руками софт? Но тогда теряется смысл yum. В моем понимании, софт посвежее в более свежих FC, но мне нужно именно для 4 версии. Как быть?  Спасибо.

Неактивен

 

#2 2007-10-29 17:22:04

Erfea
Member
Откуда: Москва
Зарегистрирован: 2007-10-26
Сообщений: 36

Re: Поясните с обновлением ПО

обновить дистриб способов дофига, но на мой взгляд для сервера важна не свежесть версии а пропатченость пакетов на секурити. Поетому юзаю цент ось на серваке.


Аццкий одмин
http://www.usrbars.com/fedora7user.png
http://img86.imageshack.us/img86/9197/mozpw8.png
http://img143.imageshack.us/img143/5137/linux01az5.png

Неактивен

 

#3 2007-10-29 20:00:04

Energy
Member
Откуда: Кемерово
Зарегистрирован: 2007-10-23
Сообщений: 439

Re: Поясните с обновлением ПО

Согласен, для сервера всё же лучше центос поставить...

Неактивен

 

#4 2007-10-30 09:12:31

Deniska
New member
Зарегистрирован: 2007-10-29
Сообщений: 4

Re: Поясните с обновлением ПО

Я со всем вышесказанным согласен, на FC сел по необходимости, у самого везде FreeBSD стоит, там с этим все понятно.
Согласен с пропатченностью пакетов. Но где их взять то? Сейчас, к примеру, с официального FC4 yum репозитория можно установить php5.0.какой-то там версии, она давно устарела, для не есть куча багфиксов, в том числе секьюрных. Так вот где ж ее пропатченную-то взять?

Неактивен

 

#5 2007-10-30 09:34:58

Energy
Member
Откуда: Кемерово
Зарегистрирован: 2007-10-23
Сообщений: 439

Re: Поясните с обновлением ПО

Думаю, что репозиторий для FC4 уже ни кто не поддерживает. Похоже тебе придётся перейти на федору 7 (или если немного потерпишь, то на федору 8) и заливать пакеты из тех репозиториев.

Неактивен

 

#6 2007-10-30 09:39:39

Erfea
Member
Откуда: Москва
Зарегистрирован: 2007-10-26
Сообщений: 36

Re: Поясните с обновлением ПО

Deniska написал:

Я со всем вышесказанным согласен, на FC сел по необходимости, у самого везде FreeBSD стоит, там с этим все понятно.
Согласен с пропатченностью пакетов. Но где их взять то? Сейчас, к примеру, с официального FC4 yum репозитория можно установить php5.0.какой-то там версии, она давно устарела, для не есть куча багфиксов, в том числе секьюрных. Так вот где ж ее пропатченную-то взять?

федора это десктоп дистриб, и паченых пакетов на старые версии никто не делает.


Аццкий одмин
http://www.usrbars.com/fedora7user.png
http://img86.imageshack.us/img86/9197/mozpw8.png
http://img143.imageshack.us/img143/5137/linux01az5.png

Неактивен

 

#7 2007-10-30 09:53:31

Deniska
New member
Зарегистрирован: 2007-10-29
Сообщений: 4

Re: Поясните с обновлением ПО

Все понятно, надо менять хостера, стало быть. Спасибо.

Неактивен

 

#8 2007-10-30 11:48:51

Erfea
Member
Откуда: Москва
Зарегистрирован: 2007-10-26
Сообщений: 36

Re: Поясните с обновлением ПО

Deniska написал:

Все понятно, надо менять хостера, стало быть. Спасибо.

хостер FC4 на сервак?! ППЦ!


Аццкий одмин
http://www.usrbars.com/fedora7user.png
http://img86.imageshack.us/img86/9197/mozpw8.png
http://img143.imageshack.us/img143/5137/linux01az5.png

Неактивен

 

#9 2007-10-30 11:56:06

Deniska
New member
Зарегистрирован: 2007-10-29
Сообщений: 4

Re: Поясните с обновлением ПО

это masterhost для VPS и VS предлагает на выбор FC2, FC4 и еще что-то, вроде RH9. Т.е. выбор невелик, к сожалению

Неактивен

 

#10 2007-12-13 19:13:26

Mikkey
Member
Откуда: Рязань
Зарегистрирован: 2007-12-13
Сообщений: 27

Re: Поясните с обновлением ПО

У меня на серваке тоже стоит "FC 4". на прошлой недели обновил ядро до 2.6.23!?
Залезь на HOTO и почитай Белунцова.
Если есть под рукой железка на которую можно поставить линуха, сделай это, собери нестандартное ядро и заставь работать cups с CANONом или XEROXом.
После этого конфигурирование и модернизация ядра и модулей — игра в тетрис.

Неактивен