Fedora linux forum

Форум русской поддержки ОС Fedora linux

 

#1 2008-02-01 14:11:10

nvl
Member
Зарегистрирован: 2007-11-01
Сообщений: 574

Myth TV --- Repository Dependency: libmp4ff.so.0 is needed by...

Кто-нибудь ставил?
Я попробовал поставить mythtv-suite с Atrpms, но не разрешаются зависимости, требует библиотеку из состава faad2 libmp4ff.so.0.
Насколько я понял, из современного faad2 библиотека libmp4ff.so.0 давно убрана.
По гуглю советуют удалить современную faad2 и поставить старую, но эти советы относятся к временам давно минувшим (упоминаются версии fc3-fc5).
Более ничего не нашел.
Если же последовать совету по удалению faad2, то в придачу поудаляется половина прог из раздела мультимедиа. Что как-то не устраивает.

Пробовал сделать libmp4ff.so.0 как символическую ссылку, все равно требует.
Может попробовать libmp4ff.so.0 взять из старого faad2 и в ручную поставить в /usr/lib?

Кто-нибудь ставил на F7 F8? Есть мысли?

Неактивен

 

#2 2008-02-01 18:25:54

cepreu
Member
Откуда: Владивосток
Зарегистрирован: 2008-01-02
Сообщений: 653

Re: Myth TV --- Repository Dependency: libmp4ff.so.0 is needed by...

А с другого репозитария поставить? Или из исходников? Еще может стоит отправить report about bug на atrpms? Пакет кривой, зависимости, мол, не разрешаются...


24 "' "The LORD bless you and keep you;
25 the LORD make his face shine upon you and be gracious to you;
26 the LORD turn his face toward you and give you peace." '
(Nu.6:24-26)

Неактивен

 

#3 2008-02-02 10:37:11

nvl
Member
Зарегистрирован: 2007-11-01
Сообщений: 574

Re: Myth TV --- Repository Dependency: libmp4ff.so.0 is needed by...

cepreu написал:

А с другого репозитария поставить? Или из исходников? Еще может стоит отправить report about bug на atrpms? Пакет кривой, зависимости, мол, не разрешаются...

C другого? Это какой ты имеешь в виду?
Из исходников можно, но не хочется засорять систему..
Несовместимости репозитариев это главная беда fedora, тогда на все пакеты надо писать report about bug

Неактивен

 

#4 2008-02-02 10:45:07

cepreu
Member
Откуда: Владивосток
Зарегистрирован: 2008-01-02
Сообщений: 653

Re: Myth TV --- Repository Dependency: libmp4ff.so.0 is needed by...

Ну там freshrpms, например. А в официальном extras этой программы нет чтоли?


24 "' "The LORD bless you and keep you;
25 the LORD make his face shine upon you and be gracious to you;
26 the LORD turn his face toward you and give you peace." '
(Nu.6:24-26)

Неактивен

 

#5 2008-02-03 09:13:07

nvl
Member
Зарегистрирован: 2007-11-01
Сообщений: 574

Re: Myth TV --- Repository Dependency: libmp4ff.so.0 is needed by...

cepreu написал:

Ну там freshrpms, например. А в официальном extras этой программы нет чтоли?

Ни где нет. Вообще мне не очень понятно, очень многих свободных программ нет в extras, которые есть и в ubuntu и в madrive и в suse...

Неактивен